Новогодняя скидка — 70% на все курсы только до 31 декабря!
Добавить материал и получить бесплатное свидетельство о публикации
версия для слабовидящих
Главная / Информатика / Самостоятельная работа по теме "Алгоритмы", 11 класс, подготовка к ЕГЭ

Самостоятельная работа по теме "Алгоритмы", 11 класс, подготовка к ЕГЭ

Вариант 1


задание 1


алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 249

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон


задание 2

алг

нач

цел n, s

n := 3

s := 0

нц пока n <= 7

    s := s + n

    n := n + 1

кц

вывод s

кон


3. Ал­го­ритм вы­чис­ле­ния зна­че­ния функ­ции F(n), где n – на­ту­раль­ное число, задан сле­ду­ю­щи­ми со­от­но­ше­ни­я­ми:

F(1) = 1

F(2) = 1

F(n) = F(n–1) * n − 2 * F(n–2), при n >2

Чему равно зна­че­ние функ­ции F(6)?

В от­ве­те за­пи­ши­те толь­ко на­ту­раль­ное число.


4. Ал­го­ритм вы­чис­ле­ния зна­че­ния функ­ции F(n), где n — на­ту­раль­ное число, задан сле­ду­ю­щи­ми со­от­но­ше­ни­я­ми:

 

F(n) = 1 при n =< 2;

F(n) = 2 · F(n − 1) + F(n − 2) при n > 2.

 

Чему равно зна­че­ние функ­ции F(7)? В от­ве­те за­пи­ши­те толь­ко на­ту­раль­ное число.


5. Ал­го­ритм вы­чис­ле­ния зна­че­ний функ­ций F(n), где n — на­ту­раль­ное число, задан сле­ду­ю­щи­ми со­от­но­ше­ни­я­ми:

 

F(1) = 1; F(2) = 2; F(3) = 3;

F(n) = F(n − 3)*n при n >3.

 

Чему равно зна­че­ние функ­ции F(11)? В от­ве­те за­пи­ши­те толь­ко на­ту­раль­ное число.













Вариант 2

задание 1

алг

нач

  цел n, s

  n := 0

  s := 0

  нц пока s < 123

    s := s + 12

    n := n + 2

  кц

  вывод n

кон



задание 2

алг

нач

цел n, s

    n : = 0

    s : = 0

    нц пока s <= 257

        s : = s + 25

        n : = n + 4

    кц

вывод n

кон



3. Ал­го­ритм вы­чис­ле­ния зна­че­ния функ­ции F(n), где n — на­ту­раль­ное число, задан сле­ду­ю­щи­ми со­от­но­ше­ни­я­ми:

 

F(1) = 1;

F(n) = F(n − 1)+n если n>1

 

Чему равно зна­че­ние функ­ции F(40)? В от­ве­те за­пи­ши­те толь­ко на­ту­раль­ное число.


4. Ал­го­ритм вы­чис­ле­ния зна­че­ния функ­ции F(n), где n — на­ту­раль­ное число, задан сле­ду­ю­щи­ми со­от­но­ше­ни­я­ми:

 

F(n) = n + 1 при n ≤ 2;

F(n) = F(n − 1) + 3 · F(n − 2) при n > 2.

 

Чему равно зна­че­ние функ­ции F(4)? В от­ве­те за­пи­ши­те толь­ко на­ту­раль­ное число.


5. Ал­го­ритм вы­чис­ле­ния зна­че­ния функ­ции F(n), где n - на­ту­раль­ное число, задан сле­ду­ю­щи­ми со­от­но­ше­ни­я­ми:

 

F(1)= 1;

F(n) = 2*F(n-1) +1 при n >1.

 

Чему равно зна­че­ние функ­ции F(5)?

 

В от­ве­те за­пи­ши­те толь­ко на­ту­раль­ное число.





Ответы:

Вариант 1


  1. 40

  2. 25

  3. 44

  4. 99

  5.  880


Вариант 2

  1. 22

  2. 44

  3.  820

  4. 18

  5. 31


  • Информатика
Описание:

Самостоятельная работа по теме "Алгоритмы" состоит из пяти заданий. Позволяет повторить тему Алгоритмы (циклический, с ветвлением, рекурсивный).

Оценивать очень легко. 5 заданий - это 5, 4 задания - это 4 и так далее.

Рекурсивный алгоритм - это прием, позволяющий свести исходную задачу к одной или нескольким более простым задачам того же типа, хотя само решение (более простое) может быть неизвестно.

Многократное повторение такого преобразования должно сходиться к базисному утверждению.

Автор Мецгер Мария Владимировна
Дата добавления 02.02.2017
Раздел Информатика
Подраздел Другое
Просмотров 891
Номер материала MA-069925
Скачать свидетельство о публикации

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

Популярные курсы