Главная / Информатика / Задачи на определение значения формулы

Задачи на определение значения формулы

7. Определение зна­че­ния формулы

1. В элек­трон­ной таб­ли­це зна­че­ние фор­му­лы =CP3HAЧ(A3:D3) равно 5. Чему равно зна­че­ние фор­му­лы =СУММ(АЗ:СЗ), если зна­че­ние ячей­ки D3 равно 6?

 

1) 1

2) -1

3) 14

4) 4

Решение.

Функ­ция СРЗНАЧ(A3:D3) счи­та­ет сред­нее ариф­ме­ти­че­ское диа­па­зо­на A3:D3, т. е. сумму зна­че­ний четырёх ячеек A3, B3, C3, D3, делённую на 4. Умно­жим сред­нее зна­че­ние на число ячеек и по­лу­чим сумму зна­че­ний ячеек A3 + B3 + C3 + D3 = 5 * 4 = 20.

 

Те­перь вы­чтем зна­че­ние ячей­ки D3 и найдём ис­ко­мую сумму: A3 + B3 + C3 = 20 - 6 = 14.

 

Пра­виль­ный ответ ука­зан под но­ме­ром 3.





2. В элек­трон­ной таб­ли­це зна­че­ние фор­му­лы =СРЗНАЧ(С2:С5) равно 3. Чему равно зна­че­ние фор­му­лы =СУММ(С2:С4), если зна­че­ние ячей­ки С5 равно 5?

 

1) 1

2) 7

3) -4

4) 4

Реше­ние.

*Для луч­ше­го по­ни­ма­ния ре­ко­мен­ду­ет­ся на­ри­со­вать таб­ли­цу.

 

Функ­ция СРЗНАЧ(С2:С5) счи­та­ет сред­нее ариф­ме­ти­че­ское диа­па­зо­на С2:С5, т. е. сумму зна­че­ний четырёх ячеек С2, С3, C4, С5, делённую на 4. Умно­жим сред­нее зна­че­ние на число ячеек и по­лу­чим сумму зна­че­ний ячеек С2 + С3 + C4 + С5 = 3 * 4 = 12

 

Те­перь, вы­чтем зна­че­ние ячей­ки С5 и найдём ис­ко­мую сумму: С2 + С3 + C4 = 12 - 5 = 7

 

Пра­виль­ный ответ ука­зан под но­ме­ром 2.



3. В элек­трон­ной таб­ли­це зна­че­ние фор­му­лы =CPЗHAЧ(C2:D5) равно 4. Чему равно зна­че­ние фор­му­лы =CУMM(C5:D5), если зна­че­ние фор­му­лы =CPЗHAЧ(C2:D4) равно 5

 

1) -6

2) 2

3) -4

4) 4

Реше­ние.

*Для луч­ше­го по­ни­ма­ния ре­ко­мен­ду­ет­ся на­ри­со­вать таб­ли­цу.

 

Функ­ция СРЗНАЧ(C2:D5) счи­та­ет сред­нее ариф­ме­ти­че­ское диа­па­зо­на C2:D5, т. е. сумму зна­че­ний вось­ми ячеек С2, D2, C3, D3, C4, D4, C5, D5, делённую на их ко­ли­че­ство. Умно­жим сред­нее зна­че­ние на 8 и найдём сумм­му зна­че­ний этих ячеек: СУММ(C2:D5) = 4 * 8 = 32.

 

Ана­ло­гич­но для CPЗHAЧ(C2:D4), ко­ли­че­ство ячеек 6: СУММ(C2:D4) = 5 * 6 = 30.

 

Вы­чтем из СУММ(C2:D5) зна­че­ние СУММ(C2:D4) и найдём зна­че­ние суммы С5 + D5: оно равно

32 - 30 = 2.

 

Пра­виль­ный ответ ука­зан под но­ме­ром 2.



4. Дан фраг­мент элек­трон­ной таб­ли­цы:

 


A

B

C

D

1

1

2

3


2

4

5

6


3

7

8

9


 

В ячей­ку D1 вве­де­на фор­му­ла =$А$1*В1+С2, а затем ско­пи­ро­ва­на в ячей­ку D2. Какое зна­че­ние в ре­зуль­та­те по­явит­ся в ячей­ке D2?

 

1) 6

2) 14

3) 16

4) 24

Реше­ние.

Часть фор­му­лы $А$1 не ме­ня­ет­ся.

В1 и С2 ме­ня­ет­ся и номер стро­ки, и номер столб­ца.

Так как фор­му­лу ско­пи­ро­ва­ли из ячей­ки D1 в D2, то номер столб­ца не из­ме­нит­ся, а номер стро­ки уве­ли­чит­ся на 1. Т. е. B1 ста­но­вит­ся B2, а C2 ста­но­вит­ся C3. Таким об­ра­зом, при ко­пи­ро­ва­нии фор­му­лы в ячей­ку D2, она будет иметь вид =$А$1*В2+С3. Под­ста­вив зна­че­ния по­лу­ча­ем: 1*5+9.

Пра­виль­ный ответ ука­зан под но­ме­ром: 2.



5. Дан фраг­мент элек­трон­ной таб­ли­цы:

 


B

C

D

69

5

10


70

6

9

=СЧЁТ(B69:C70)

71



=СРЗНАЧ(B69:D70)

 

После пе­ре­ме­ще­ния со­дер­жи­мо­го ячей­ки C70 в ячей­ку C71 зна­че­ние в ячей­ке D71 из­ме­нит­ся по аб­со­лют­ной ве­ли­чи­не на:

 

1) 2,2

2) 2,0

3) 1,02

4) 0,8

Реше­ние.

Зна­че­ние в ячей­ке D70 до пе­ре­ме­ще­ния — 4 (все че­ты­ре ячей­ки (B69:C70) за­ня­ты), а в ячей­ке D71 — 6,8 ((B69+C69+B70+C70+D70)/5).

Зна­че­ние в ячей­ке D70 после пе­ре­ме­ще­ния — 3 (ячей­ка С70 стала пу­стой), а в ячей­ке D71 — 6((B69+C69+B70+D70)/4).

6,8-6=0,8

Ответ:0,8



6. В ячей­ке G4 элек­трон­ной таб­ли­цы за­пи­са­на фор­му­ла. Эту фор­му­лу ско­пи­ро­ва­ли в ячей­ку F3. В ре­зуль­та­те зна­че­ние в ячей­ке F3 вы­чис­ля­ет­ся по фор­му­ле 2xy, где x – зна­че­ние в ячей­ке C22, а y – зна­че­ние в ячей­ке D22. Ука­жи­те, какая фор­му­ла могла быть на­пи­са­на в ячей­ке G4.

 

1) =2C22D22

2) =2$C22$D22

3) =2C$22D$22

4) =2D$22$D23

Реше­ние.

Ва­ри­ант 1 не под­хо­дит, так как при пе­ре­но­се фор­му­лы =2C22D22 из G4 в F3 она из­ме­нит­ся на =2B21C21.

 

Ва­ри­ант 2 не под­хо­дит, так как при пе­ре­но­се фор­му­лы =2$C22$D22 из G4 в F3 она из­ме­нит­ся на =2$C21$D21.

 

Ва­ри­ант 3 не под­хо­дит, так как при пе­ре­но­се фор­му­лы =2C$22D$22 из G4 в F3 она из­ме­нит­ся на =2B$22C$22.

 

Ва­ри­ант 4 под­хо­дит, так как при пе­ре­но­се фор­му­лы =2D$22$D23 из G4 в F3 она из­ме­нит­ся на =2C$22$D22.

Пра­виль­ный ответ ука­зан под но­ме­ром: 4.



Задачи на определение значения формулы
  • Информатика
Описание:

Даны задачи по информатике на определение значения формулы. Материалы полезны учителям и учащимся для подготовки к ЕГЭ по информатике. 

Пример. В элек­трон­ной таб­ли­це зна­че­ние фор­му­лы =CP3HAЧ(A3:D3) равно 5. Чему равно зна­че­ние фор­му­лы =СУММ(АЗ:СЗ), если зна­че­ние ячей­ки D3 равно 6?

  1) 1                2)-1         3) 14       4) 4

Решение.   Функ­ция СРЗНАЧ(A3:D3) счи­та­ет сред­нее ариф­ме­ти­че­ское диа­па­зо­на A3:D3, т. е. сумму зна­че­ний четырёх ячеек A3, B3, C3, D3, делённую на 4. Умно­жим сред­нее зна­че­ние на число ячеек и по­лу­чим сумму зна­че­ний ячеек A3 + B3 + C3 + D3 = 5 * 4 = 20. Те­перь вы­чтем зна­че­ние ячей­ки D3 и найдём ис­ко­мую сумму: A3 + B3 + C3 = 20 - 6 = 14.

Пра­виль­ный ответ ука­зан под но­ме­ром 3.

 

Автор Хакимзянова Нурания Идерисовна
Дата добавления 26.12.2014
Раздел Информатика
Подраздел
Просмотров 743
Номер материала 12455
Скачать свидетельство о публикации

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

↓ Показать еще коментарии ↓