Главная / Информатика / Практическая работа «Принятие решений в VBA»

Практическая работа «Принятие решений в VBA»

БЮДЖЕТНОЕ ОБРАЗОВАТЕЛЬНОЕ УЧРЕЖДЕНИЕ ОМСКОЙ ОБЛАСТИ
«ОМСКИЙ АВИАЦИОННЫЙ КОЛЛЕДЖ ИМЕНИ Н.Е. ЖУКОВСКОГО»

МЕТОДИЧЕСКИЕ РЕКОМЕНДАЦИИ
преподавателя Мирошниченко В.А.
по выполнению практической работы «Принятие решений в VBA»

МДК.01.02 Прикладное программирование

ПМ.01 Разработка программных модулей программного обеспечения для компьютерных систем











Оглавление






Принятие решений в VBA

Цели занятия:

Изучить некоторые возможности организации диалога с пользователем.

Освоить приемы использования различных элементов управления.

Изучить некоторые возможности организации диалога с пользователем.

Освоить приемы использования различных элементов управления.


Задание 1

Некоторая фирма предлагает клиентам выбор путешествия по каталогу. Создайте диалоговое окно, в котором при выборе вида путешествия демонстрируется средство передвижения и показывается стоимость.

  1. Создайте книгу Excel, назовите ее Магазин.

  2. Первый лист назовите Travel. На этом листе в ячейку А1 будет помещаться номер путешествия, в зависимости от выбранного клиентом элемента OptionButton, а в ячейке В1 будет формироваться стоимость при помощи функции ВЫБОР (рисунок 4).



A

B

C

D

E

F

1

2

=ВЫБОР($A$1;25;75;40)


2







3







Рисунок

Цены возьмите из таблицы 8.

Таблица

Путешествие

Стоимость

Морской круиз

$25

Полет на луну

$75

Автопробег

$40


  1. Создайте пользовательское диалоговое окно. Разместите три Переключателя в элементе Рамка; затем три Рисунка; Надпись и Поле, в котором будет выводиться цена; одну Кнопку.

  2. Установите свойства рисунков, а затем совместите их.

  3. Установите свойства Name, Caption для остальных элементов.

  4. Добавьте код в вашу программу.

  5. Сравните ваш код с примером:

Private Sub btnEnd_Click()

End

End Sub

Private Sub optOcean_Click()

ImgOcean.Visible = True

ImgMoon.Visible = False

ImgCar.Visible = False

Range("Travel!A1").Value = 1

TxtPrace.Value = Range("Travel!В1").Value

End Sub

Private Sub OptMoon_Click()

ImgOcean.Visible = False

ImgMoon.Visible = True

ImgCar.Visible = False

Range("Travel!A1").Value = 2

TxtPrace.Value = Range("Travel!В1").Value

End Sub

Private Sub OptCar_Click()

ImgOcean.Visible = False

ImgMoon.Visible = False

ImgCar.Visible = True

Range("Travel!A1").Value = 3

TxtPrace.Value = Range("Travel!В1").Value

End Sub

  1. Проверьте работу программы.

Задание 2

Фирма предлагает сувениры по каталогу. Клиент может выбрать несколько сувениров, их изображения будут появляться при выборе флажка и располагаться рядом, а общая стоимость высвечиваться в поле ввода по щелчку мыши на кнопке Сумма.

  1. В книге Магазин откройте чистый лист, назовите его Suvenir.

  2. Создайте структуру таблицы Excel в соответствии с рисунком 5:


A

B

C

D

E

1

Товар

Цена

Стоимость покупки

Покупка

Сумма

2

1

20

=ЕСЛИ(D2=ИСТИНА;B2;0)


=СУММ(С1:С5)

3

2

35

=ЕСЛИ(D3=ИСТИНА;B3;0)



4

3

17

=ЕСЛИ(D4=ИСТИНА;B4;0)



5

4

47

=ЕСЛИ(D5=ИСТИНА;B5;0)



Рисунок

  1. Создайте пользовательское диалоговое окно и установите свойства элементов управления в соответствии с таблицей 9.

Таблица

Объект

Свойство

Установка

CheckBox

Name

chkRose

ControlSource

Suvenir!d2

CheckBox

Name

chkCar

ControlSource

Suvenir!d3

CheckBox

Name

chkClock

ControlSource

Suvenir!d4

CheckBox

Name

chkPicture

ControlSource

Suvenir!d5

Image

Name

(Произвольно)

Picture

(Произвольно)

PictureAlignment

2

PictureSizeMode

3

BorderStyle

0

SpesialEffect

3

Name

False

CommandButton

Name

btnSum

Caption

Сумма

CommandButton

Name

btnCancel

Caption

Сброс

TextBox

Name

txtSum

UserForm

Name

frmSuvenir

Caption

Сувениры


  1. Добавьте код обработки событий:

Private Sub chkRose _Click()

If chkRose.Value = True Then

ImgRose.Visible = True

Else

ImgRose.Visible = False

End If

End Sub

Private Sub chkCar _Click()

If chkCar.Value = True Then

ImgCar.Visible = True

Else

ImgCar.Visible = False

End If

End Sub

Private Sub chkClock _Click()

If chkClock.Value = True Then

ImgClock.Visible = True

Else

ImgClock.Visible = False

End If

End Sub

Private Sub chkPicture _Click()

If chkPicture.Value = True Then

ImgPicture.Visible = True

Else

ImgPicture.Visible = False

End If

End Sub

Private Sub btnEnd_Click()

End

End Sub

Private Sub btnSum _Click()

TxtSum.Value = Range("Suvenir!g2")

End Sub

Private Sub btnCancel _Click()

ImgRose.Visible = False

ImgCar.Visible = False

ImgClock.Visible = False

ImgPicture.Visible = False

chkRose.Value = False

chkCar.Value = False

chkClock.Value = False

chkPicture.Value = False

End

End Sub

  1. Завершите работу с программой.

Проверь себя

Запишите в тетрадь ответы на контрольные вопросы и решения ситуаций.

  1. В каких случаях применяется элемент управления OptionButton?

  2. В каких случаях применяется элемент управления CheckBox?

  3. Какие связи устанавливает свойство ControlSource?

  4. Ситуация 1: Пользователь желает, чтобы в определенном месте экрана появлялась фотография того или иного сотрудника, отмеченного в списке.

  5. Ситуация 2: Пользователь щелкает на кнопке «К оплате», однако сумма на экран не выводится.


2014 г.

Практическая работа «Принятие решений в VBA»
  • Информатика
Описание:

Методические рекомендации по выполнению практической работы "Принятие решений в VBA" предназначены для студентов и всех желающих самостоятельно освоить работу в среде Visual Basic for Application. В задании 1 предлагается создать диалоговое окно, в котором при выборе вида путешествия демонстрируется средство передвижения и показывается стоимость.

В задании 2 предлагаетсяиспользовать элементы управления

CheckBox.

При написании кода обработчика событий студент использует структуры принятия решений.

Автор Мирошниченко Вера Алексеевна
Дата добавления 22.12.2014
Раздел Информатика
Подраздел
Просмотров 386
Номер материала 9951
Скачать свидетельство о публикации

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

↓ Показать еще коментарии ↓