Главная / Информатика / Составление комбинированных алгоритмов для исполнителя Робот 9 класс

Составление комбинированных алгоритмов для исполнителя Робот 9 класс

Название документа Индивидуальные задания.doc

hello_html_m6be1b9bf.gif

hello_html_71023905.gif

hello_html_275747d6.gif

hello_html_267ece8e.gif

hello_html_m646e8f4f.gif

hello_html_1628a4c2.gif

hello_html_760cb74e.gif

hello_html_690f85ab.gif

hello_html_6c0679d5.gif

hello_html_m23d32923.gif

hello_html_61c0e44f.gif

hello_html_m3f5df207.gif

hello_html_m55ccf321.gif

hello_html_3171aa6b.gif


Название документа Исполнитель Робот_2.ppt

Команда условия. Составление комбинированных алгоритмов *
Ответьте на вопросы Формат команды повторить, цикла пока. Есть ли разница в и...
Команда ветвления если  то действия 1 иначе действия 2 конец если  то действи...
Пример Робот находится в горизонтальном коридоре, нижняя граница которого спл...
Упражнения В ряду клеток левее Робота некоторые клетки закрашены. Составьте а...
Упражнения а) повторить 10 раз влево если закрашено то вниз; закрась; вверх к...
Задание 1 Составьте алгоритм прохождения Робота по коридору (размер поля и фо...
Решение нц пока сверху свободно или справа свободно если сверху свободно то в...
Задание 2 Известно, что Робот находится внутри коридора (длина коридора неизв...
Решение нц пока снизу свободно закрась; вниз кц закрась нц пока сверху свобод...
Решение нц пока не сверху свободно и не снизу свободно закрась; вправо кц вле...
Задание 3 Известно, что Робот находится над стеной (длина стены неизвестна). ...
Решение нц пока не снизу свободно вправо кц вниз влево нц пока не сверху своб...
ДЗ Составьте алгоритм закрашивания Роботом всех клеток поля. Размер поля 6X8....
Решение задачи ДЗ 1 способ: Повторить 8 раз 	закрась 	повторить 5 раз 	 вправ...
1 из 16

Описание презентации по отдельным слайдам:

№ слайда 1 Команда условия. Составление комбинированных алгоритмов *
Описание слайда:

Команда условия. Составление комбинированных алгоритмов *

№ слайда 2 Ответьте на вопросы Формат команды повторить, цикла пока. Есть ли разница в испо
Описание слайда:

Ответьте на вопросы Формат команды повторить, цикла пока. Есть ли разница в использовании этих команд? Что представляют собой составные условия? Какие логические связки в них используются? Составьте условие, которое будет означать, что Робот находится в левом верхнем углу поля. Составьте условие, которое будет означать, что Робот не находится в левом нижнем углу поля. Составьте условие, проверяющее, что с одной из сторон клетки, где находится Робот, есть стена.

№ слайда 3 Команда ветвления если  то действия 1 иначе действия 2 конец если  то действия 1
Описание слайда:

Команда ветвления если <условие> то действия 1 иначе действия 2 конец если <условие> то действия 1 конец

№ слайда 4 Пример Робот находится в горизонтальном коридоре, нижняя граница которого сплошн
Описание слайда:

Пример Робот находится в горизонтальном коридоре, нижняя граница которого сплошная, а в верхней имеются выходы. Провести Робота через коридор и закрасить клетки коридора, не имеющие верхних границ. вправо нц пока не снизу свободно если сверху свободно то закрась конец вправо кц *

№ слайда 5 Упражнения В ряду клеток левее Робота некоторые клетки закрашены. Составьте алго
Описание слайда:

Упражнения В ряду клеток левее Робота некоторые клетки закрашены. Составьте алгоритм, который закрашивает клетки ниже каждой закрашенной клетки. Рассмотрите задачу для случаев, когда а) известно общее количество клеток левее Робота (например, 10 клеток). б) общее количество клеток левее Робота неизвестно. Клетки, которые надо закрасить *

№ слайда 6 Упражнения а) повторить 10 раз влево если закрашено то вниз; закрась; вверх коне
Описание слайда:

Упражнения а) повторить 10 раз влево если закрашено то вниз; закрась; вверх конец конец Клетки, которые надо закрасить б) нц пока слева свободно влево если закрашено то вниз; закрась; вверх конец кц *

№ слайда 7 Задание 1 Составьте алгоритм прохождения Робота по коридору (размер поля и форма
Описание слайда:

Задание 1 Составьте алгоритм прохождения Робота по коридору (размер поля и форма коридора произвольные) от левого нижнего угла поля к правому верхнему. Коридор имеет ширину одна клетка и тянется слева-снизу вправо-вверх. Б *

№ слайда 8 Решение нц пока сверху свободно или справа свободно если сверху свободно то ввер
Описание слайда:

Решение нц пока сверху свободно или справа свободно если сверху свободно то вверх иначе вправо конец кц если сверху свободно то вверх конец если справа свободно то вправо конец Б *

№ слайда 9 Задание 2 Известно, что Робот находится внутри коридора (длина коридора неизвест
Описание слайда:

Задание 2 Известно, что Робот находится внутри коридора (длина коридора неизвестна). Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение. а) б) * *

№ слайда 10 Решение нц пока снизу свободно закрась; вниз кц закрась нц пока сверху свободно
Описание слайда:

Решение нц пока снизу свободно закрась; вниз кц закрась нц пока сверху свободно вверх кц *

№ слайда 11 Решение нц пока не сверху свободно и не снизу свободно закрась; вправо кц влево
Описание слайда:

Решение нц пока не сверху свободно и не снизу свободно закрась; вправо кц влево нц пока не сверху свободно и не снизу свободно влево кц вправо нц пока не закрашено закрась; вправо кц *

№ слайда 12 Задание 3 Известно, что Робот находится над стеной (длина стены неизвестна). Сос
Описание слайда:

Задание 3 Известно, что Робот находится над стеной (длина стены неизвестна). Составить алгоритм для закрашивания Роботом всех клеток под стеной. Конечное положение Робота может быть произвольным. *

№ слайда 13 Решение нц пока не снизу свободно вправо кц вниз влево нц пока не сверху свободн
Описание слайда:

Решение нц пока не снизу свободно вправо кц вниз влево нц пока не сверху свободно закрась влево кц *

№ слайда 14 ДЗ Составьте алгоритм закрашивания Роботом всех клеток поля. Размер поля 6X8.
Описание слайда:

ДЗ Составьте алгоритм закрашивания Роботом всех клеток поля. Размер поля 6X8. *

№ слайда 15
Описание слайда:

№ слайда 16 Решение задачи ДЗ 1 способ: Повторить 8 раз 	закрась 	повторить 5 раз 	 вправо
Описание слайда:

Решение задачи ДЗ 1 способ: Повторить 8 раз закрась повторить 5 раз вправо закрась конец повторить 5 раз влево конец если сверху свободно то вверх конец конец 2 способ (размер поля произвольный): нц пока сверху свободно или не закрашено закрась нц пока справа свободно вправо закрась кц если сверху свободно то вверх закрась нц пока слева свободно влево закрась кц конец если сверху свободно то вверх конец кц

Название документа К-т урока.doc

Тема урока: Составление комбинированных алгоритмов для исполнителя Робот

Цели урока:

  1. образовательная:

    • обобщение и систематизация знаний по теме Алгоритмы,

    • формирование навыков практического применения знаний;

  2. воспитательная:

    • воспитание ответственности, самостоятельности, самооценки, аккуратности при выполнении работы;

    • повышение информационной культуры учащихся;

  3. развивающая:

    • формирование и развитие у учащихся познавательных интересов;

    • развитие умения оперировать ранее полученными знаниями, сопоставлять, анализировать, делать выводы.

Тип урока: комбинированный.

Оборудование:

  • проектор,

  • компьютерный класс

План урока

  1. Организационный момент - 2 мин.

  2. Проверка усвоения материала - 8 мин.

  3. Объяснение материала и выполнение упражнений - 15 мин.

  4. Закрепление материала - 15 мин.

  5. Вопросы учеников, ДЗ, подведение итогов урока –5 мин.

Ход урока

Организационный момент

Приветствие, проверка присутствующих.

Сегодня мы продолжаем работу с исполнителем Робот. К нашему арсеналу средств для управления исполнителем Робот мы добавим еще одну очень полезную команду и потренируемся составлять алгоритмы для решения разнообразных задач, связанных с нашим исполнителем.

Проверка усвоения материала

Начнем с проверки ДЗ (проверяется наличие ДЗ, выслушиваются и обсуждаются варианты решений).

А теперь ответим на следующие вопросы:

  1. Вспомните форматы команды повторить, цикла пока.

  2. Есть ли разница в использовании этих команд?

  3. Что представляют собой составные условия? Какие логические связки в них используются?

  4. Составьте условие, которое будет означать, что Робот находится в левом верхнем углу поля.

  5. Составьте условие, которое будет означать, что Робот не находится в левом нижнем углу поля.

  6. Составьте условие, проверяющее, что с одной из сторон клетки, где находится Робот, есть стена.

Объяснение нового материала с использование проектора

Вспомним алгоритмическую структуру «ветвление». Она используется при необходимости выполнения разных действий в зависимости от выполнения определенного условия. Частным и более простым случаем такой структуры является структура «обход» - по одной из ветвей действия не выполняются (слайд №3).

На алгоритмическом языке структура «ветвление» выглядит так:

если <условие> то

действия 1

иначе

действия 2

конец

А структура «обход» так: если <условие> то

действия 1

конец

Рассмотрим пример использования такой структуры (рис.1) и выполним упражнение (рис. 2).

hello_html_3f9d77cb.gif

Рис. 1

hello_html_m24c61eb.gif

Рис. 2

Упражнение (рис.2):

а) повторить 10 раз

влево

если закрашено то

вниз; закрась; вверх

конец

конец

б) нц пока слева свободно

влево

если закрашено то

вниз; закрась; вверх

конец

кц

Закрепление материала

Учащиеся самостоятельно выполняют задания, после чего происходит проверка и обсуждение решений.

Задание 1. Составьте алгоритм прохождения Робота по коридору (размер поля и форма коридора произвольные) от левого нижнего угла поля к правому верхнему. Коридор имеет ширину одна клетка и тянется слева-снизу вправо-вверх.







hello_html_m2766ded6.gif

нц пока сверху свободно или справа свободно

если сверху свободно то

вверх

иначе

вправо

конец

кц

Конструкцию «ветвление» можно заменить более простой структурой «обход»:

если сверху свободно то

вверх

конец

если справа свободно то

вправо

конец

Задание 2. Известно, что Робот находится внутри коридора (длина коридора неизвестна). Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение.

hello_html_659a4aca.gif

а) нц пока снизу свободно

закрась; вниз

кц

закрась

нц пока сверху свободно

вверх

кц



б) нц пока не сверху свободно и не снизу свободно

закрась; вправо

кц

влево

нц пока не сверху свободно и не снизу свободно

влево

кц

вправо

нц пока не закрашено

закрась; вправо

кц

Задание 3. Известно, что Робот находится над стеной (длина стены неизвестна). Составить алгоритм для закрашивания Роботом всех клеток под стеной. Конечное положение Робота может быть произвольным.

hello_html_m6b41dd97.gif

нц пока не снизу свободно

вправо

кц

вниз

влево

нц пока не сверху свободно

закрась

влево

кц





ДЗ, подведение итогов урока

Домашнее задание: составьте алгоритм закрашивания Роботом всех клеток поля. Размер поля 6х8.

Возможные решения:

1 способ (с использованием команды «повторить», закрашивается поле заданного размера):

Повторить 8 раз

закрась

повторить 5 раз

вправо

закрась

конец

повторить 5 раз

влево

конец

если сверху свободно то

вверх

конец

конец

2 способ (с использованием цикла «пока», размер поля может быть произвольным):

нц пока сверху свободно или не закрашено

закрась

нц пока справа свободно

вправо

закрась

кц

если сверху свободно то

вверх

закрась

нц пока слева свободно

влево

закрась

кц

конец

если сверху свободно то

вверх

конец

кц

Ответы на вопросы учащихся, выставление оценок за работу на уроке.

Надеюсь, что сегодняшний урок убедил вас в важности и полезности алгоритмической структуры «ветвление» и научил вас ей пользоваться. А также мы еще раз потренировались в составлении алгоритмов для решения разных задач исполнителем Робот. Благодарю всех за внимание.

4


Составление комбинированных алгоритмов для исполнителя Робот 9 класс
  • Информатика
Описание:

Тема урока: Составление комбинированных алгоритмов для исполнителя Робот
Цели урока:

  1. образовательная:
  • обобщение и систематизация знаний по теме Алгоритмы,
  • формирование навыков практического применения знаний;
воспитательная:
  • воспитание ответственности, самостоятельности, самооценки, аккуратности при выполнении работы;
  • повышение информационной культуры учащихся;
развивающая:
  • формирование и развитие у учащихся познавательных интересов;
  • развитие умения оперировать ранее полученными знаниями, сопоставлять, анализировать, делать выводы.

Тип урока: комбинированный.
Оборудование:

  • проектор,
  • компьютерный класс

План урока

  1. Организационный момент - 2 мин.
  2. Проверка усвоения материала - 8 мин.
  3. Объяснение материала и выполнение упражнений - 15 мин.
  4. Закрепление материала - 15 мин.
  5. Вопросы учеников, ДЗ, подведение итогов урока –5 мин.

Ход урока
Организационный момент
Приветствие, проверка присутствующих.
Сегодня мы продолжаем работу с исполнителем Робот. К нашему арсеналу средств для управления исполнителем Робот мы добавим еще одну очень полезную команду и потренируемся составлять алгоритмы для решения разнообразных задач, связанных с нашим исполнителем.
Проверка усвоения материала
Начнем с проверки ДЗ (проверяется наличие ДЗ, выслушиваются и обсуждаются варианты решений).
А теперь ответим на следующие вопросы:

  • Вспомните форматы команды повторить, цикла пока.
  • Есть ли разница в использовании этих команд?
  • Что представляют собой составные условия? Какие логические связки в них используются?
  • Составьте условие, которое будет означать, что Робот находится в левом верхнем углу поля.
  • Составьте условие, которое будет означать, что Робот не находится в левом нижнем углу поля.
  • Составьте условие, проверяющее, что с одной из сторон клетки, где находится Робот, есть стена.

Объяснение нового материала с использование проектора
Вспомним алгоритмическую структуру «ветвление». Она используется при необходимости выполнения разных действий в зависимости от выполнения определенного условия. Частным и более простым случаем такой структуры является структура «обход» - по одной из ветвей действия не выполняются (слайд №3).
На алгоритмическом языке структура «ветвление» выглядит так:
если <условие> то
            действия 1
иначе
            действия 2
конец
А структура «обход» так:    если <условие> то
действия 1
 конец
Рассмотрим пример использования такой структуры (рис.1) и выполним упражнение (рис. 2).


sh13.gif
Рис. 1

sh14.gif
Рис. 2

Упражнение (рис.2):


а) повторить 10 раз
       влево
       если закрашено то
            вниз; закрась; вверх
       конец
    конец        

б) нц пока слева свободно
       влево
       если закрашено то
            вниз; закрась; вверх
       конец
    кц

Закрепление материала
Учащиеся самостоятельно выполняют  задания, после чего происходит проверка и обсуждение решений.
Задание 1. Составьте алгоритм прохождения Робота по коридору (размер поля и форма коридора произвольные) от левого нижнего угла поля к правому верхнему. Коридор имеет ширину одна клетка и тянется слева-снизу вправо-вверх.

 

 

sh15.gif

нц пока  сверху свободно или  справа свободно
    если сверху свободно то
        вверх
    иначе
        вправо
    конец
кц
Конструкцию «ветвление» можно заменить более простой структурой «обход»:
если сверху свободно то
    вверх
конец
если справа свободно то
    вправо
конец

Задание 2. Известно, что Робот находится внутри коридора (длина коридора неизвестна).  Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение.


sh16.gif

а) нц пока снизу свободно
   закрась; вниз
кц
закрась
нц пока сверху свободно
   вверх
кц

б) нц пока не сверху свободно и не снизу свободно
   закрась; вправо
кц
влево
нц пока не сверху свободно и не снизу свободно
   влево
кц
вправо
нц пока не закрашено
   закрась; вправо
кц

Задание 3. Известно, что Робот находится над стеной (длина стены неизвестна).  Составить алгоритм для закрашивания Роботом всех клеток под стеной. Конечное положение Робота может быть произвольным.


sh17.gif

нц пока не снизу свободно
   вправо
кц
вниз
влево
нц пока не сверху свободно
   закрась
   влево
кц


ДЗ, подведение итогов урока
Домашнее задание: составьте алгоритм закрашивания Роботом всех клеток поля. Размер поля 6х8.
Возможные решения:
1 способ  (с использованием команды «повторить», закрашивается поле заданного размера):
Повторить 8 раз
            закрась
            повторить 5 раз
                 вправо
                 закрась
            конец
            повторить 5 раз
                 влево
            конец
            если сверху свободно то
                 вверх
            конец
конец
2 способ (с использованием цикла «пока», размер поля может быть произвольным):
нц пока сверху свободно или не закрашено
            закрась
            нц пока справа свободно
                 вправо
                 закрась
            кц
            если сверху свободно то
                 вверх
                 закрась
                 нц пока слева свободно
                      влево
                      закрась
                 кц
            конец
            если сверху свободно то
                 вверх
            конец
кц
Ответы на вопросы учащихся, выставление оценок за работу на уроке.
Надеюсь, что сегодняшний урок убедил вас в важности и полезности алгоритмической структуры «ветвление» и научил вас ей пользоваться. А также мы еще раз потренировались в составлении алгоритмов для решения разных задач исполнителем Робот. Благодарю всех за внимание.

Литература:
1. Л Босова. Информатика и ИКТ. Учебник для 7 класса. М., Бином, Лаборатория знаний, 2010.
2. А.Г. Кушниренко, Г.В. Лебедев, Я.Н. Зайдельман. Информатика 7-9 кл. М., Дрофа, 2003.







dop.pngДополнительно:

Демонстрационный материал к уроку информатики в 9 классе «Составление комбинированных алгоритмов для исполнителя Робот» (16 слайдов)

Слайд 1
sh18.png


Слайд 7
sh19.png
Автор Шалтырева Ольга Сергеевна
Дата добавления 04.01.2011
Раздел Информатика
Подраздел
Просмотров 2994
Номер материала 640
Скачать свидетельство о публикации

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

↓ Показать еще коментарии ↓