Главная / Информатика / Составление циклических алгоритмов для исполнителя Робот 9 класс

Составление циклических алгоритмов для исполнителя Робот 9 класс

Название документа Исполнитель Робот_1.ppt

Повторение Определите понятие Исполнитель. Приведите примеры. Чем формальный ...
Исполнитель Робот СКИ: вверх вниз влево вправо закрась Проверка отсутствия ст...
Упражнения Петя составил алгоритм, переводящий Робота из клетки А в клетку Б ...
Упражнения Составьте алгоритм, с помощью которого Робот сможет попасть в точк...
Команда «Повторить» Повторить … раз последовательность команд конец Повторить...
Упражнения Составьте алгоритмы, под управлением которых Робот закрасит следую...
Цикл «Пока» нц пока  последовательность команд кц Закрасить все клетки до сте...
Упражнения Закрасить все клетки до стены справа от робота и вернуться в исход...
Составные условия Образуются из одного или нескольких простых условий и служе...
Задание Используя команды повторить и пока перевести Робота из исходного поло...
Задание Известно, что Робот находится рядом с входом в коридор (длина коридор...
ДЗ Известно, что Робот находится рядом с входом в коридор (длина коридора неи...
1 из 14

Описание презентации по отдельным слайдам:

№ слайда 1
Описание слайда:

№ слайда 2 Повторение Определите понятие Исполнитель. Приведите примеры. Чем формальный исп
Описание слайда:

Повторение Определите понятие Исполнитель. Приведите примеры. Чем формальный исполнитель отличается от неформального? Приведите примеры. Что такое СКИ? Назовите СКИ Калькулятор. Какие требования накладываются на алгоритмы, предназначенные для выполнения исполнителем?

№ слайда 3 Исполнитель Робот СКИ: вверх вниз влево вправо закрась Проверка отсутствия стены
Описание слайда:

Исполнитель Робот СКИ: вверх вниз влево вправо закрась Проверка отсутствия стены и цвета клетки: сверху свободно снизу свободно справа свободно слева свободно закрашено *

№ слайда 4 Упражнения Петя составил алгоритм, переводящий Робота из клетки А в клетку Б с з
Описание слайда:

Упражнения Петя составил алгоритм, переводящий Робота из клетки А в клетку Б с закрашиванием каких-то клеток. Что должен сделать Коля с этим алгоритмом, чтобы перевести Робота из Б в А с закрашиванием тех же клеток? Петя составил алгоритм, при выполнении которого Робот вернулся в исходное положение. Коля стер одну из команд. При выполнении Колиного алгоритма Робот также вернулся в исходное положение. Какую команду стер Коля?

№ слайда 5 Упражнения Составьте алгоритм, с помощью которого Робот сможет попасть в точку Б
Описание слайда:

Упражнения Составьте алгоритм, с помощью которого Робот сможет попасть в точку Б во всех трех лабиринтах. * Б * Б * Б

№ слайда 6 Команда «Повторить» Повторить … раз последовательность команд конец Повторить 5
Описание слайда:

Команда «Повторить» Повторить … раз последовательность команд конец Повторить 5 раз вверх; вверх; вправо; вниз; вниз; вправо конец * * * * * * * Б

№ слайда 7 Упражнения Составьте алгоритмы, под управлением которых Робот закрасит следующие
Описание слайда:

Упражнения Составьте алгоритмы, под управлением которых Робот закрасит следующие клетки: * *

№ слайда 8 Цикл «Пока» нц пока  последовательность команд кц Закрасить все клетки до стены
Описание слайда:

Цикл «Пока» нц пока <условие> последовательность команд кц Закрасить все клетки до стены справа от робота нц пока справа свободно вправо закрась кц *

№ слайда 9 Упражнения Закрасить все клетки до стены справа от робота и вернуться в исходное
Описание слайда:

Упражнения Закрасить все клетки до стены справа от робота и вернуться в исходное положение нц пока справа свободно вправо закрась кц нц пока закрашено влево кц *

№ слайда 10 Составные условия Образуются из одного или нескольких простых условий и служебны
Описание слайда:

Составные условия Образуются из одного или нескольких простых условий и служебных слов И, ИЛИ, НЕ. Пусть А = сверху свободно В = справа свободно и А выполнено (=1) В выполнено (=1) А ИЛИ В 1 А И В 1 НЕ А 0 НЕ В 0 НЕ А ИЛИ НЕ В 0 НЕ А ИЛИ В 1 А ИЛИ НЕ В 1 НЕ А И НЕ В 0 НЕ А И В 0 А И НЕ В 0 *

№ слайда 11 Задание Используя команды повторить и пока перевести Робота из исходного положен
Описание слайда:

Задание Используя команды повторить и пока перевести Робота из исходного положения в точку Б, если количество клеток по вертикали и длина стен в лабиринте неизвестны. повторить 5 раз нц пока не справа свободно вверх кц вправо нц пока не справа свободно вниз кц вправо конец * Б

№ слайда 12 Задание Известно, что Робот находится рядом с входом в коридор (длина коридора н
Описание слайда:

Задание Известно, что Робот находится рядом с входом в коридор (длина коридора неизвестна). Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение. *

№ слайда 13 ДЗ Известно, что Робот находится рядом с входом в коридор (длина коридора неизве
Описание слайда:

ДЗ Известно, что Робот находится рядом с входом в коридор (длина коридора неизвестна). Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение. а) б) Составьте алгоритм для закрашивания Роботом клеток: * *

№ слайда 14
Описание слайда:

Название документа К-т урока.doc

Тема урока: Составление циклических алгоритмов для исполнителя Робот

Цели урока:

  1. образовательная:

    • обобщение и систематизация знаний по теме Алгоритмы,

    • формирование навыков практического применения знаний;

  2. воспитательная:

    • воспитание ответственности, самостоятельности, самооценки, аккуратности при выполнении работы;

    • повышение информационной культуры учащихся;

  3. развивающая:

    • формирование и развитие у учащихся познавательных интересов;

    • развитие умения оперировать ранее полученными знаниями, сопоставлять, анализировать, делать выводы.

Тип урока: комбинированный.

Оборудование:

  • проектор,

  • компьютерный класс

План урока

  1. Организационный момент - 2 мин.

  2. Актуализация знаний - 8 мин.

  3. Объяснение материала и выполнение упражнений - 20 мин.

  4. Закрепление материала - 10 мин.

  5. Вопросы учеников, ДЗ, подведение итогов урока –5 мин.

Ход урока

Организационный момент

Приветствие, проверка присутствующих.

На предыдущих уроках мы говорили об алгоритмах, рассматривали их типы, виды, свойства, составляли алгоритмы для решения разных задач. Сегодня мы будем использовать алгоритмы для управления исполнителями. И для начала вспомним, что же такое «исполнитель».

Актуализация знаний

Учащиеся отвечают на следующие вопросы:

  • Определите понятие Исполнитель. Приведите примеры.

  • Чем формальный исполнитель отличается от неформального? Приведите примеры.

  • Что такое СКИ? Назовите СКИ Калькулятор.

  • Какие требования накладываются на алгоритмы, предназначенные для выполнения исполнителем?

Объяснение нового материала с использование проектора

Среда исполнителя Робот – клетчатое поле, ограниченное стеной. Внутри поля между некоторыми клетками также может быть стена. Исполнитель Робот может перемещаться на одну клетку с помощью команд перемещения вправо, влево, вверх, вниз. Также он может закрашивать клетки, на которых стоит, командой закрась. Если между клетками стена, то Робот не может ее пройти. Команды проверки отсутствия стены и закрашенности клетки: сверху свободно, снизу свободно, справа свободно, слева свободно, закрашено (рис. 1).

Упражнения:

  1. Петя составил алгоритм, переводящий Робота из клетки А в клетку Б с закрашиванием каких-то клеток. Что должен сделать Коля с этим алгоритмом, чтобы перевести Робота из Б в А с закрашиванием тех же клеток?

  2. Петя составил алгоритм, при выполнении которого Робот вернулся в исходное положение. Коля стер одну из команд. При выполнении Колиного алгоритма Робот также вернулся в исходное положение. Какую команду стер Коля?

  3. См. рис.2

hello_html_cc842ae.gif

Рис. 1

hello_html_170e275a.gif

Рис.2

Рассмотрим задачу: составить алгоритм для перемещения Робота в точку Б (рис. 3). Очевидно, что здесь выделяются последовательности повторяющихся команд. В этом случае удобно воспользоваться алгоритмической структурой Цикл. Вопрос: какие циклические структуры алгоритма вы помните (ответ: цикл-до, цикл-после, цикл с заданным количеством повторений). В данном случае нам известно количество поворений, поэтому воспользуемся командой Повторить (рис. 4):

hello_html_63e14cd1.gif

Рис. 3

hello_html_418b03a9.gif

Рис. 4

В окончательном варианте алгоритм выполнения этой задачи будет выглядеть так:

Повторить 5 раз

вверх; вверх; вправо; вниз; вниз; вправо

конец

Упражнения (рис. 5).

А теперь рассмотрим следующую задачу: закрасить все клетки до стены справа от Робота при условии, что количество клеток до стены неизвестно (рис. 6). В этом случае воспользуемся алгоритмической конструкцией Цикл-после (т.е. цикл выполняется после проверки условия).

hello_html_m7c063a76.gif

Рис. 5

hello_html_m601aedb6.gif

Рис. 6

Упражнение: в предыдущей задаче нужно закрасить все клетки справа от Робота и вернуться в исходное положение.

Ответ: нц пока справа свободно

вправо

закрась

кц

нц пока закрашено

влево

кц

Составные условия образуются из одного или нескольких простых условий и служебных слов И, ИЛИ, НЕ. Чтобы составное условие, объединяющее простые условия логической связкой ИЛИ было истинным, достаточно истинности одного из простых условий, входящих в него. Чтобы составное условие, объединяющее простые условия логической связкой И было истинным, необходимо, чтобы истинны были все простые условия, входящие в него (рис. 7).

hello_html_m3c31b9a8.gif

Рис. 7

hello_html_m10f5542b.gif

Рис. 8

Закрепление материала

Задания выполняются в рабочих тетрадях с последующим обсуждением предложенных учащимися решений.

Задание 1. Используя команды повторить и пока перевести Робота из исходного положения в точку Б, если количество клеток по вертикали и длина стен в лабиринте неизвестны (рис. 8).

Ответ: повторить 5 раз

нц пока не справа свободно

вверх

кц

вправо

нц пока не справа свободно

вниз

кц

вправо

конец

Задание 2. Известно, что Робот находится рядом с входом в коридор (длина коридора неизвестна). Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение (рис. 9).

Ответ: вправо

нц пока не сверху свободно и не снизу свободно

закрась

вправо

кц

влево

нц пока закрашено

влево

кц

hello_html_5ff0aba7.gif

Рис. 9

hello_html_m2dc7e290.gif

Рис. 10

ДЗ, подведение итогов урока

Ответы на вопросы учащихся, домашнее задание (рис. 10), выставление оценок за работу на уроке.

Сегодня мы научились управлять Роботом, использовать циклические алгоритмы для оптимизации задачи составления алгоритма, поняли, что при составлении алгоритмов надо быть предельно внимательными и точными. На следующем уроке мы продолжим знакомиться с различными вариантами алгоритмов для Робота. Благодарю всех за внимание.

hello_html_m53d4ecad.gif

4


Составление циклических алгоритмов для исполнителя Робот 9 класс
  • Информатика
Описание:

Цели урока:

  1. образовательная:
  • обобщение и систематизация знаний по теме Алгоритмы,
  • формирование навыков практического применения знаний;
воспитательная:
  • воспитание ответственности, самостоятельности, самооценки, аккуратности при выполнении работы;
  • повышение информационной культуры учащихся;
развивающая:
  • формирование и развитие у учащихся познавательных интересов;
  • развитие умения оперировать ранее полученными знаниями, сопоставлять, анализировать, делать выводы.

Тип урока: комбинированный.

Оборудование:

  • проектор,
  • компьютерный класс

План урока

  1. Организационный момент - 2 мин.
  2. Актуализация знаний - 8 мин.
  3. Объяснение материала и выполнение упражнений - 20 мин.
  4. Закрепление материала - 10 мин.
  5. Вопросы учеников, ДЗ, подведение итогов урока –5 мин.

Ход урока
Организационный момент
Приветствие, проверка присутствующих.
На предыдущих уроках мы говорили об алгоритмах, рассматривали их типы, виды, свойства, составляли алгоритмы для решения разных задач. Сегодня мы будем использовать алгоритмы для управления исполнителями. И для начала вспомним, что же такое «исполнитель».
Актуализация знаний
Учащиеся отвечают на следующие вопросы:

  • Определите понятие Исполнитель. Приведите примеры.
  • Чем формальный исполнитель отличается от неформального? Приведите примеры.
  • Что такое СКИ? Назовите СКИ Калькулятор.
  • Какие требования накладываются на алгоритмы, предназначенные для выполнения исполнителем?

Объяснение нового материала с использование проектора
Среда исполнителя Робот – клетчатое поле, ограниченное стеной. Внутри поля между некоторыми клетками также может быть стена. Исполнитель Робот может перемещаться на одну клетку с помощью команд перемещения вправо, влево, вверх, вниз. Также он может закрашивать клетки, на которых стоит, командой закрась. Если между клетками стена, то Робот не может ее пройти. Команды проверки отсутствия стены и закрашенности клетки: сверху свободно, снизу свободно, справа свободно, слева свободно, закрашено (рис. 1).
Упражнения:

  • Петя составил алгоритм, переводящий Робота из клетки А в клетку Б с закрашиванием каких-то клеток. Что должен сделать Коля с этим алгоритмом, чтобы перевести Робота из Б в А с закрашиванием тех же клеток?
  • Петя составил алгоритм, при выполнении которого Робот вернулся в исходное положение. Коля стер одну из команд. При выполнении Колиного алгоритма Робот также вернулся в исходное положение. Какую команду стер Коля?
  • См. рис.2

sha3.gif
Рис. 1

sha4.gif
Рис.2

Рассмотрим задачу: составить алгоритм для перемещения Робота в точку Б (рис. 3). Очевидно, что здесь выделяются последовательности повторяющихся команд. В этом случае удобно воспользоваться алгоритмической структурой Цикл. Вопрос: какие циклические структуры алгоритма вы помните (ответ: цикл-до, цикл-после, цикл с заданным количеством повторений). В данном случае нам известно количество поворений, поэтому воспользуемся командой Повторить (рис. 4):


sha5.gif
Рис. 3

sha6.gif
Рис. 4

В окончательном варианте алгоритм выполнения этой задачи будет выглядеть так:
Повторить 5 раз
   вверх; вверх; вправо; вниз; вниз; вправо
конец
Упражнения (рис. 5).
А теперь рассмотрим следующую задачу: закрасить все клетки до стены справа от Робота при условии, что количество клеток до стены неизвестно (рис. 6). В этом случае воспользуемся алгоритмической конструкцией Цикл-после (т.е. цикл выполняется после проверки условия).


sha7.gif
Рис. 5

sha8.gif
Рис. 6

Упражнение: в предыдущей задаче нужно закрасить все клетки справа от Робота и вернуться в исходное положение.
Ответ:        нц пока справа свободно
    вправо
    закрась
кц
нц пока закрашено
    влево
кц
Составные условия образуются из одного или нескольких простых условий и служебных слов И, ИЛИ, НЕ. Чтобы составное условие, объединяющее простые условия логической связкой ИЛИ было истинным, достаточно истинности одного из простых условий, входящих в него. Чтобы составное условие, объединяющее простые условия логической связкой И было истинным, необходимо, чтобы истинны были все простые условия, входящие в него (рис. 7).


sha9.gif
Рис. 7

sha10.gif
Рис. 8

Закрепление материала
Задания выполняются в рабочих тетрадях с последующим обсуждением предложенных учащимися решений.
Задание 1. Используя команды повторить и пока перевести Робота из исходного положения в точку Б, если количество клеток по вертикали и длина стен в лабиринте неизвестны (рис. 8).
Ответ:                  повторить 5 раз
   нц пока не справа свободно
        вверх
   кц
   вправо
   нц пока не справа свободно
        вниз
   кц
   вправо
конец
Задание 2. Известно, что Робот находится рядом с входом в коридор (длина коридора неизвестна).  Составить алгоритм для закрашивания Роботом всех клеток коридора и возвращения его в исходное положение (рис. 9).
Ответ:      вправо
нц пока не сверху свободно и не снизу свободно
       закрась
       вправо
кц
влево
нц пока закрашено
       влево
кц


sha11.gif
Рис. 9

sha12.gif
Рис. 10

ДЗ, подведение итогов урока
Ответы на вопросы учащихся, домашнее задание (рис. 10), выставление оценок за работу на уроке.
Сегодня мы научились управлять Роботом, использовать циклические алгоритмы для оптимизации задачи составления алгоритма, поняли, что при составлении алгоритмов надо быть предельно внимательными и точными. На следующем уроке мы продолжим знакомиться с различными вариантами алгоритмов для Робота. Благодарю всех за внимание.

Литература:
1. Л Босова. Информатика и ИКТ. Учебник для 7 класса. М., Бином, Лаборатория знаний, 2010.
2. А.Г. Кушниренко, Г.В. Лебедев, Я.Н. Зайдельман. Информатика 7-9 кл. М., Дрофа, 2003.







dop.pngДополнительно:

Демонстрационный материал к уроку информатики в 9 классе «Составление циклических алгоритмов для исполнителя Робот» (14 слайдов)

Слайд 1
sha1.png


Слайд 3
sha3.png


Слайд 7
sha7.png
Автор Шалтырева Ольга Сергеевна
Дата добавления 03.01.2011
Раздел Информатика
Подраздел
Просмотров 4489
Номер материала 639
Скачать свидетельство о публикации

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

↓ Показать еще коментарии ↓