Главная / Информатика / Лабораторно-практическая работа № 14 «Функции даты и времени MS Excel 2003»

Лабораторно-практическая работа № 14 «Функции даты и времени MS Excel 2003»

Документы в архиве:

25 КБ Дата и время.xls
395 КБ ПР_13_Функции даты и времени.doc

Название документа ПР_13_Функции даты и времени.doc

wehqiowueh2323f.doc

Практикум №13 «Функции даты и времени»


Выполнив задания этой темы, вы научитесь:

  • Технологии создания и форматирования табличного документа;

  • Использовать встроенные функции даты и времени Excel для расчетов.


Задание.

Технология выполнения работы:

  1. Запустить приложение Excel.

  2. В ячейку A1 введите следующую формулу, которая при помощи функции СЕГОДНЯ отображает текущую дату: =”Сегодня:”&ТЕКСТ(СЕГОДНЯ();”ДДММММГГГГ”). В ячейку A2:A4 введите текст по образцу (рис. 1). В ячейки введите числа, которые соответствуют сегодняшнему дню, месяцу, году.

  3. Для того чтобы из года (ячейка В2), месяца (ячейка ВЗ) и дня (ячейка В4) собрать дату, введите в ячейку В5 формулу =ДАТА(В2;ВЗ;В4) (рис. 2).

  4. А чтобы из даты (ячейка В5) извлечь год, месяц и день, в ячейки В6, В7 и В8 введите соответственно следующие формулы: =”Год:”&ГОД(В5), =”Месяц:”&МЕСЯЦ(В5), =”День:”&ДЕНЬ(В5).

  5. В

    Рисунок 1

    hello_html_m53bd55ac.jpgведите в ячейки C1 и С2 текст, а в ячейки D1 и D2 даты, выделив эти ячейки и измените тип данных. Для этого: Формат ячеек – Число – Дата – ЧЧ.ММ.ГГГГ (14.03.2001).
  6. Предположим, вам надо посчитать продолжительность работы в днях между начальной (ячейка D1) и конечной датами (ячейка D2). Для этого можно ввести в ячейку D3 формулу
    =D2-D1+1. Но ведь нам надо знать количество дней в числовом формате. Тогда формула должна быть вот такой: =ТЕКСТ(D2-D1+1;"###"). Здесь мы применяем автоматическое форматирование.

Аhello_html_3881c101.jpg

Рисунок 2

если мы хотим узнать, каким по порядку днем года является данная дата (ячейка D4) (см. как в образце)? Очень просто: в ячейку D5 введите формулу =D4-ДАТА(ГОД(D4);1;0), которая находит разность между данной датой и 1 января того же года. В результате может получиться значение в виде даты, выделив ячейку D5 переведем в числовой формат. Формат – Ячеек – Число – Числовой тип и Знаков после запятой – 0.
  1. Или вот такая задача: определить, является ли данная дата (ячейка D4) субботой или воскресеньем? Введите в ячейку D6 следующую формулу: =ЕСЛИ(ИЛИ(ДЕНЬНЕД  (D4;2)=6;ДЕНЬНЕД(D4;2)=7);”Суббота или Воскресенье”;””). В ней применена функция ДЕНЬНЕД, которая возвращает номер дня недели заданной даты. Если указанная дата попала на субботу или воскресенье, то именно это и будет указано в ячейке, если нет, то не будет указано ничего.

  2. Для определения текущего времени надо из текущих даты и времени, возвращаемых в числовом формате функцией ТДАТА, вычесть текущую дату (функция СЕГОДНЯ), а результат (ячейка В11) перевести в формат времени: =ТЕКСТ(ТДАТА()-СЕГОДНЯ();"ЧЧ:ММ:СС").

  3. Введите в ячейки B12, B13, B14 значения часов, минут и секунд в соответствии с образцом (рис. 1). Чтобы из часов (В12), минут (В13) и секунд (В14) «собрать» время, введите в ячейку В15 формулу =ВРЕМЯ (В12;В13;В14). В ячейки A17 – A19, B17 – B19 введите данные в соответствии с образцом (рис. 1). А чтобы найти суммарный промежуток времени (В17, В18, В19), в ячейку В20 введите формулу =СУММ(В17:В19). Если суммарный промежуток времени, как для данных из диапазона D17:D19, больше 24 часов, то простого суммирования будет недостаточно. В этом случае результат надо отформатировать (D20), причем часовую составляющую заключить в квадратные скобки, как это сделано в формуле =ТЕКСТ(СУММ (D17:D19);“[Ч]:ММ”).


2


Лабораторно-практическая работа № 14 «Функции даты и времени MS Excel 2003»
  • Информатика
Описание:

Выполнив задания этой темы, вы научитесь:

  • Технологии создания и форматирования табличного документа;

  • Использовать встроенные функции даты и времени Excel 2003 для расчетов.

Задание.

098.jpg
  1. Запустить приложение Excel 2003.

  2. В ячейку A1 введите следующую формулу, которая при помощи функции СЕГОДНЯ отображает текущую дату: ="Сегодня:"&ТЕКСТ(СЕГОДНЯ();"ДД ММММ ГГГГ"). В ячейку A2:A4 введите текст по образцу (см. рис.). В ячейки введите числа, которые соответствуют сегодняшнему дню, месяцу, году.

  3. Для того чтобы из года (ячейка В2), месяца (ячейка ВЗ) и дня (ячейка В4) собрать дату, введите в ячейку В5 формулу =ДАТА(В2;ВЗ;В4) (Окно: Аргументы функции).

    096.jpg
  4. А чтобы из даты (ячейка В5) извлечь год, месяц и день, в ячейки В6, В7 и В8 введите соответственно следующие формулы: =Год:"&ГОД(В5), ="Месяц:"&МЕСЯЦ(В5), ="День:"&ДЕНЬ(В5).

  5. Введите в ячейки C1 и С2 текст, а в ячейки D1 и D2 даты, выделив эти ячейки и измените тип данных. Для этого: Формат ячеек – Число – Дата – ЧЧ.ММ.ГГГГ (14.03.2001).

  6. Предположим, вам надо посчитать продолжительность работы в днях между начальной (ячейка D1) и конечной датами (ячейка D2). Для этого можно ввести в ячейку D3 формулу =D2-D1+1. Но ведь нам надо знать количество дней в числовом формате. Тогда формула должна быть вот такой: =ТЕКСТ(D2-D1+1;"≠≠≠"). Здесь мы применяем автоматическое форматирование. А если мы хотим узнать, каким по порядку днем года является данная дата (ячейка D4) (см. как в образце)? Очень просто: в ячейку D5 введите формулу =D4-ДАТА(ГОД(04);1;0), которая находит разность между данной датой и 1 января того же года. В результате может получиться значение в виде даты, выделив ячейку D5 переведем в числовой формат. Формат – Ячеек – Число – Числовой тип и Знаков после запятой – 0.

  7. Или вот такая задача: определить, является ли данная дата (ячейка D4) субботой или воскресеньем? Введите в ячейку D6 следующую формулу: =ЕСЛИ(ИЛИ(ДЕНЫНЕД (D4;2)=6;ДЕНЬНЕД(D4;2)=7);"Суббота или Воскресенье";»»). В ней применена функция ДЕНЬНЕД, которая возвращает номер дня недели заданной даты. Если указанная дата попала на субботу или воскресенье, то именно это и будет указано в ячейке, если нет, то не будет указано ничего.

  8. Для определения текущего времени надо из текущих даты и времени, возвращаемых в числовом формате функцией ТДАТА, вычесть текущую дату (функция СЕГОДНЯ), а результат (ячейка В11) перевести в формат времени: =ТЕКСТ(ТДАТА()-СЕГОДНЯ();"ЧЧ:ММ:СС").

  9. Введите в ячейки B12, B13, B14 значения часов, минут и секунд в соответствии с образцом (см. рис.). Чтобы из часов (В12), минут (В13) и секунд (В14) «собрать» время, введите в ячейку В15 формулу =ВРЕМЯ (В12;В13;В14). В ячейки A17 – A19, B17 – B19 введите данные в соответствии с образцом. А чтобы найти суммарный промежуток времени (В17, В18, В19), в ячейку В20 введите формулу =СУММ(В17:В19). Если суммарный промежуток времени, как для данных из диапазона D17:D19, больше 24 часов, то простого суммирования будет недостаточно. В этом случае результат надо отформатировать (D20), причем часовую составляющую заключить в квадратные скобки, как это сделано в формуле =ТЕКСТ(СУММ (D17:D19);«[Ч]:ММ»).



Используемая литература:

  1. Макарова Н.В. Программа по информатике (системно-информационная концепция). К комплекту учебников по информатике 5-11 класс. Санкт-Петербург: Питер.2000г.
  2. Информатика. 5-11 класс. /Под ред. Н.В. Макаровой. – СПб.: Питер, 2001
  3. Коляда М.Г. Окно в удивительный мир информатики. ИКФ «Сталкер»,1997
  4. Шафрин Ю.А. Основы компьютерной технологии. Учебное пособие для 7 – 11 классов по курсу «Информатика и вычислительная техника» - Москва: ABF,1996
  5. Ефимова О.В., Моисеева М.В., Ю.А. Шафрин Практикум по компьютерной технологии. Примеры и упражнения. Пособие по курсу «Информатика и вычислительная техника» - Москва: ABF,1997
  6. Горячев А., Шафрин Ю. Практикум по информационным технологиям. М.: Лаборатория базовых знаний, 2001
  7. Семакин И.Г., Шеина Т.Ю. Преподавание курса информатики в средней школе. М.: Лаборатория базовых знаний, 2002
  8. Симонович С.В., Евсеев Г.А. Практическая информатика. Учебное пособие для средней школы. Универсальный курс. – Москва: АСТ-ПРЕСС: Информ-Пресс, 1998
  9. Симонович С.В. Компьютер в вашей школе. М.: АСТ-ПРЕСС: Информком-Пресс, 2001
  10. Симонович С.В., Евсеев Г.А. Занимательный компьютер. Книга для детей, учителей и родителей. Москва: АСТ-ПРЕСС: Информком-Пресс, 2002
Автор
Дата добавления 08.03.2008
Раздел Информатика
Подраздел
Просмотров 3307
Номер материала 243

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

↓ Показать еще коментарии ↓