Главная / Информатика / Контрольная работа на тему "Среда программирования Кумир. Исполнитель Робот. Циклы и ветвления".

Контрольная работа на тему "Среда программирования Кумир. Исполнитель Робот. Циклы и ветвления".

Название документа #U041e#U0442#U0432#U0435#U0442#U044b.doc

Вариант 1

1.

использовать Робот
алг
нач
. нц пока справа свободно
. . вправо
. кц
. нц пока снизу свободно
. . вниз
. кц
. закрасить
. нц пока слева свободно
. . влево
. . закрасить
. кц
. нц пока сверху свободно
. . вверх
. кц
. закрасить
. нц пока справа свободно
. . вправо
. . закрасить
. кц
кон
























2.

использовать Робот
алг
нач
. нц 3 раз
. . вправо
. . вправо
. . вправо
. . вниз
. . влево
. . влево
. . влево
. . вниз
. кц
кон













3.

использовать Робот
алг
нач
. нц пока не слева свободно
. . закрасить
. . вверх
. кц
. вниз
. нц пока справа свободно
. . вправо
. . закрасить
. кц
. нц пока не справа свободно
. . закрасить
. . вниз
. кц
. вверх
кон



















4.

использовать Робот
алг
нач
. нц пока снизу стена
. . если сверху свободно
. . . то закрасить
. . все
. . вправо
. кц
кон











Вариант 2

1.

использовать Робот
алг
нач
. нц пока сверху свободно
. . вверх
. кц
. нц пока справа свободно
. . вправо
. кц
. закрасить
. нц пока снизу свободно
. . вниз
. . закрасить
. кц
. нц пока слева свободно
. . влево
. кц
. закрасить
. нц пока сверху свободно
. . вверх
. . закрасить
. кц
кон






















2.

использовать Робот
алг
нач
. нц 3 раз
. . вверх
. . вверх
. . вверх
. . вправо
. . вниз
. . вниз
. . вниз
. . вправо
. кц
кон













3. использовать Робот
алг
нач
.
нц пока слева стена
. .
закрасить
. .
вверх
.
кц
.
нц пока не снизу стена
. .
вниз
.
кц
.
нц пока не снизу свободно
. .
закрасить
. .
вправо
.
кц
.
влево
.
нц пока слева свободно
. .
вверх
.
кц
.
нц пока слева стена
. .
закрасить
. .
вверх
.
кц
.
вниз
кон

4.

использовать Робот
алг
нач
. нц пока сверху стена
. . если снизу свободно
. . . то закрасить
. . все
. . вправо
. кц
кон












Название документа #U043a#U043e#U043d#U0442#U0440#U043e#U043b#U044c#U043d#U0430#U044f #U0440#U0430#U0431#U043e#U0442#U0430.docx

Вариант 1hello_html_m5dcdbd7d.jpg


  1. Исполнитель Робот находится где-то внутри огороженного пространства, имеющего форму прямоугольника. Размеры прямоугольника неизвестны. Составьте алгоритм, закрашивающий все клетки, расположенные в первой и последней строке прямоугольника.






hello_html_bbcfa03.jpg



  1. Составить алгоритм, который переместит Робота из начального положения в положение, отмеченное звёздочкой. Задачу решить для конкретного рисунка, применяя команду «цикл N раз».







hello_html_42124379.jpg



  1. Перевести исполнитель из начального положения в положение, отмеченное звёздочкой, закрасив при этом отмеченные клетки. Длина стен и расстояние между ними неизвестны.







hello_html_67617a65.jpg

  1. Создать программу, проводящую Робота через коридор произвольной длины. По пути Робот должен закрасить все клетки, у которых сверху нет стены (стена снизу окон не имеет). Количество окон сверху неизвестно.










Вариант 2hello_html_m5dcdbd7d.jpg


  1. Исполнитель Робот находится где-то внутри огороженного пространства, имеющего форму прямоугольника. Размеры прямоугольника неизвестны. Составьте алгоритм, закрашивающий все клетки, расположенные в первом и последнем столбце прямоугольника.





hello_html_m717d910a.jpg




  1. Составить алгоритм, который переместит Робота из начального положения в положение, отмеченное звёздочкой. Задачу решить для конкретного рисунка, применяя команду «цикл N раз».






hello_html_m440bdd84.jpg



  1. Перевести исполнитель из начального положения в положение, отмеченное звёздочкой, закрасив при этом отмеченные клетки. Длина стен и расстояние между ними неизвестны.






hello_html_126163d0.jpg


  1. Создать программу, проводящую Робота через коридор произвольной длины. По пути Робот должен закрасить все клетки, у которых снизу нет стены (стена сверху окон не имеет). Количество окон снизу неизвестно.




Контрольная работа на тему "Среда программирования Кумир. Исполнитель Робот. Циклы и ветвления".
  • Информатика
Описание:

Данная разработка предназначена для контроля знаний и умений обучающихся по теме "Среда программирования Кумир. Исполнитель Робот. Циклы и ветвления".

Исполнитель Робот в среде программирования Кумир рекомендуется изучать в 9 классе.

Задания составлены на основе контрольно-измерительных материалов, которые входят в базу обязательного государственного экзамена. Каждое задание представлено в текстовом виде и графическом. Программу можно разработать, как в среде программирования Кумир, так и в текстовом редакторе.

Ответы учеников могут отличаться от представленных, но программа должна выполняться, не зацикливаясь и Робот не должен разрушиться.

Автор Митрофанова Людмила Николаевна
Дата добавления 31.10.2016
Раздел Информатика
Подраздел Другое
Просмотров 53
Номер материала MA-068190
Скачать свидетельство о публикации

Оставьте свой комментарий:

Введите символы, которые изображены на картинке:

Получить новый код
* Обязательные для заполнения.


Комментарии:

↓ Показать еще коментарии ↓